[arin-tech-discuss] Problem creating customer record using ARIN REST REG API

David Huberman dhuberma at arin.net
Sun Dec 23 10:08:40 EST 2012

Hello Jarl,

If you privately send me the full URL you're using, with your real API key, and the payload, I'll do my best to help you out today.  I'll then report back to the list when we figure something out :)



From: arin-tech-discuss-bounces at arin.net [arin-tech-discuss-bounces at arin.net] on behalf of Jarl Stefansson [jarl.stefansson at gmail.com]
Sent: Sunday, December 23, 2012 1:22 AM
To: arin-tech-discuss at arin.net
Subject: [arin-tech-discuss] Problem creating customer record using ARIN REST REG API


I'm building a python library to communicate with the ARIN REST REG API and until I ran into the following issue everything has worked great.

 I'm able to retrieve/modify Net and Customer objects without any issues but when I try to create a new Customer I'm getting the following error, I've consulted with the documentation and as far as I can see I'm following it to the letter, perhaps someone here can assist, I've included the error I receive from the API but with modified NET and API keys for security/privacy reasons.

DEBUG:root:request() HTTP Response content b'
<title>JBoss Web/7.0.10.Final - Error report</title>
<!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}-->
HTTP Status 404 - Could not find resource for relative : /net/NET-192-168-0-0-1/customer of full path: http://jboss1.cha.arin.net:8080/regcore/seam/resource/rest/net/NET-192-168-0-0-1/customer?apikey=API-DEAD-BEEF-CAFE-1234
<HR size="1" noshade="noshade">
<p><b>type</b> Status report</p>
<p><b>message</b> <u>Could not find resource for relative : /net/NET-192-168-0-0-1/customer of full path: http://jboss1.cha.arin.net:8080/regcore/seam/resource/rest/net/NET-192-168-0-0-1/customer?apikey=API-DEAD-BEEF-CAFE-1234</u></p>
The requested resource (Could not find resource for relative : /net/NET-192-168-0-0-1/customer of full path: http://jboss1.cha.arin.net:8080/regcore/seam/resource/rest/net/NET-192-168-0-0-1/customer?apikey=API-DEAD-BEEF-CAFE-1234) is not available.
<HR size="1" noshade="noshade">
<h3>JBoss Web/7.0.10.Final</h3>

p.s. I will be releasing the library under GPL v.3 once finished.


Jarl Stefansson
jarl.stefansson at gmail.com<mailto:jarl.stefansson at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.arin.net/pipermail/arin-tech-discuss/attachments/20121223/ac14df35/attachment.html>

More information about the arin-tech-discuss mailing list